Back to overview
Downtime

Afterword Login is Down

Jun 12 at 02:22pm EDT
Affected services
Platform: Case Management, Online Planner, Chain of Custody

Resolved
Jun 12 at 02:51pm EDT

We’re seeing reports that the Afterword platform is back online. You should be able to login to Afterword like normal again, although it may take time for all our systems to catch up.

This outage impacted nearly all cloud providers (Google, AWS, Cloudflare, Azure). Still—we are working through ways to mitigate this risk in the future.

Created
Jun 12 at 02:22pm EDT

Our third-party provider Google is having an outage with our authentication system. We're actively working with their team to resolve the issue as quickly as possible.